‹ Home Tech & Security

During Days

$52.99$62.95Save $9.96 (15%)

Inc. GST. Free shipping on this item.

Secure checkout: Visa Mastercard AMEX PayPal Shop Pay

Shipping Calculator

Delivering to your area Change
14-day returns Change of mind
1-year warranty ACL backed
Aussie owned Expert support available

Description

+

Features

1300 (867+400)Mbps wireless speed

Support 2.4GHz & 5GHz WLAN networks

Dual Band connections for lag-free HD video streaming and gaming

SuperSpeed USB 3.0 port, backward compatible to USB 2.0

Complies with IEEE 802.11ac, IEEE 802.11n, IEEE 802.11g, IEEE 802.11b standards

20MHz & 40MHz & 80MHz bandwidth transmission

OFDM with BPSK, QPSK, 16QAM, 64QAM, 256QAMmodulation

Supports Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Specification

Hardware 

Ports: USB 3.0

Button: WPS 

LED: 1 X Link/ Active

Chipset:RTL8812AU 

Flash: N/A 

SDRAM: N/A 

Power Supply: USB 5V 

Power Plug: N/A 

Power Consumption:

Rated Voltage/ requency /current:DC 5V about 500mA

Wireless 

Standard:IEEE802.11ac,IEEE 802.11a, IEEE 802.11b,IEEE 802.11g,IEEE 802.11n

Modulation:

11ac\n: 16QAM, 64QAM 128QAM 256QAM with OFDM

11g: BPSK, QPSK, 16QAM, 64QAM, OFDM

11b: DQPSK, DBPSK, DSSS, CCK 

Speed:

802.11ac: up to 867Mbps 

802.11n: up to 400Mbps 

802.11a: up to 54Mbps 

802.11g: 54 M 

802.11b: 11 M 

Frequency band:5GHz and 2.4GHz 

Power: 

802.11b: 22dBm ± 2 dBm 802.11g: 16dBm ± 2 dBm 

802.11n: 15dBm ± 2 dBm 802.11ac: 14dBm ± 2 dBm 

Distance:Outdoors 300m, Indoor 100m(According to the actual environment change)

Safely 64/128-bit WEP, AES,TKIP,WPA,WPA2,802.1x,WPA-PSK,WPA2-PSK,MAC, WDS

Environmental 

Operating Temperature:0ºC~40ºC 

Storage Temperature:-10~70  

Relative Humidity(Operational): 10%~90%,noncondensing 

Relative Humidity(Storage):10%~90%,noncondensing

Software

Standard Version 

RFC768 User Datagram Protocol(UDP)

RFC791 Internet Protocol(IP) 

RFC792 Internet Control Message Protocol

RFC793 Transmission Control Protocol(TCP)

bandwidth 20MHz & 40MHz & 80MHz

Wireless Mode 11ac only, 11n only, 11g only & 11b only(option)

System Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Product weight and dimensions

Item Weight: 0.25 KG

Product Dimensions: 98mm L x 28mm W x 10mm (L x W x H)

Package content

1 x Wireless-AC USB3.0 Aapter

1 x Quick Installation

V28-USBWIN688U3

1 x CD driver

Shipping & returns

+
Shipping. Dispatched within 1–3 business days with tracking. Most metro deliveries arrive within 2–8 business days.

Returns. Change of mind within 14 days for store credit, item unused and in original packaging, return postage at your cost. Faulty or damaged items are a full refund or replacement under Australian Consumer Law.

Customer reviews

No reviews on this product yet
4.27 ★ store rating from 559 reviews across During Days
Change

Check if we ship free to you

Enter your postcode and suburb — takes 10 seconds.

Only used to show relevant shipping & deals. Never shared.